summaryrefslogtreecommitdiffstats
path: root/utils/sys-utils/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bentele2020-09-09 16:53:48 +0200
committerManuel Bentele2020-09-16 07:37:56 +0200
commit87c9cd859ca10ccbe109e09fe01a03b08932a887 (patch)
tree31bdd21158857dcecbf91d85b1e5ade62033d8f2 /utils/sys-utils/CMakeLists.txt
parentAdded patched losetup utility to configure xloop devices (diff)
downloadxloop-87c9cd859ca10ccbe109e09fe01a03b08932a887.tar.gz
xloop-87c9cd859ca10ccbe109e09fe01a03b08932a887.tar.xz
xloop-87c9cd859ca10ccbe109e09fe01a03b08932a887.zip
Added CMake files to build xloop kernel modules and xlosetup utility
Diffstat (limited to 'utils/sys-utils/CMakeLists.txt')
-rw-r--r--utils/sys-utils/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/utils/sys-utils/CMakeLists.txt b/utils/sys-utils/CMakeLists.txt
index 1e007dc..a36e88c 100644
--- a/utils/sys-utils/CMakeLists.txt
+++ b/utils/sys-utils/CMakeLists.txt
@@ -7,3 +7,8 @@ project(xloop-utils-sys-utils)
add_executable(xlosetup ${CMAKE_CURRENT_SOURCE_DIR}/losetup.c)
target_link_libraries(xlosetup LINK_PUBLIC libcommon libsmartcols)
target_include_directories(xlosetup PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}/../lib ${CMAKE_CURRENT_SOURCE_DIR}/../libsmartcols)
+install(TARGETS xlosetup DESTINATION bin)
+
+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/losetup.8
+ DESTINATION /usr/share/man/man8
+ PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ) \ No newline at end of file