summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStepan Kasal2007-05-15 20:46:30 +0200
committerKarel Zak2007-05-16 11:43:31 +0200
commit0b9f737e0b28c96ea38af2002cf9d33fbf95c844 (patch)
tree44c7c1ec301ddea93f73a74f4d51cd46b86eb1e1 /Makefile.am
parentbuild-sys: remove po/Makevars.template from EXTRA_DIST (diff)
downloadkernel-qcow2-util-linux-0b9f737e0b28c96ea38af2002cf9d33fbf95c844.tar.gz
kernel-qcow2-util-linux-0b9f737e0b28c96ea38af2002cf9d33fbf95c844.tar.xz
kernel-qcow2-util-linux-0b9f737e0b28c96ea38af2002cf9d33fbf95c844.zip
build-sys: in the clean targets use "find ... | xargs rm -f"
"find ... -exec rm {}" is unnecessarily slow. Signed-off-by: Stepan Kasal <skasal@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 490e98bf1..1b91651f0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,12 +27,12 @@ EXTRA_DIST = \
distclean-local:
- -find . \( -name \*~ -o -name \*.orig -o -name \*.rej \) -exec rm -f {} \;
+ -find . -name \*~ -o -name \*.orig -o -name \*.rej | xargs rm -f
rm -rf autom4te.cache
mrproper: distclean
if [ -f ".gitignore" ]; then \
- find -name Makefile.in -exec rm -f {} \; ; \
+ find -name Makefile.in | xargs rm -f ; \
rm -f configure ABOUT-NLS ; \
rm -rf m4 ; \
cd config; rm -f `cat ../.gitignore`; cd .. ; \