summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2010-08-19 15:33:45 +0200
committerKarel Zak2010-08-19 15:33:45 +0200
commit0c0f93fcc37d02d9ab6d159f964da378d424199e (patch)
treed8ab6318379cea0f9f2b23e8d4a99a2434c64d6b /Makefile.am
parenttests: add blkid test for partitioned RAID0 (diff)
downloadkernel-qcow2-util-linux-0c0f93fcc37d02d9ab6d159f964da378d424199e.tar.gz
kernel-qcow2-util-linux-0c0f93fcc37d02d9ab6d159f964da378d424199e.tar.xz
kernel-qcow2-util-linux-0c0f93fcc37d02d9ab6d159f964da378d424199e.zip
fsck: improve whole-disk check, detect stacked devices
The current heuristic for conversion from partition to whole-disk is based on device names. It's pretty poor. This patch replaces this code with blkid_devno_to_wholedisk(). This solution is based on /sys FS and it works for arbitrary partitioned devices. The another problem is the way how fsck determines stacked devices. The current code checks device name for "md" prefix only. It does not care about DM, dm-ccypt, and so on. This patch uses /sys/block/.../slaves/, but it does not fully resolves dependencies between all devices. The method is simple -- fsck does not check stacked devices in parallel with any other device. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c489665f5..9febbfd9b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,8 +44,10 @@ SUBDIRS += mount
endif
if BUILD_FSCK
+if BUILD_LIBBLKID
SUBDIRS += fsck
endif
+endif
ACLOCAL_AMFLAGS = -I m4