summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2012-08-03 21:24:51 +0200
committerKarel Zak2012-08-03 21:24:51 +0200
commit1b03e2cd33a059fdd355c52899e151130777c44f (patch)
treeb6eac3caf34c4bfb0127e67819b32190a11f0cea /Makefile.am
parentbuild-sys: add tests/run-nonroot.sh to automake file (diff)
downloadkernel-qcow2-util-linux-1b03e2cd33a059fdd355c52899e151130777c44f.tar.gz
kernel-qcow2-util-linux-1b03e2cd33a059fdd355c52899e151130777c44f.tar.xz
kernel-qcow2-util-linux-1b03e2cd33a059fdd355c52899e151130777c44f.zip
tests: make compatible with autotools
The command 'make check' is called from 'make distcheck' (which is used to generate official util-linux tarballs). It means that tests/ stuff has to be compatible with autotools and differentiate between source and build directories. * remove run-nonroot.sh (merged into run.sh * remove commands.sh.in * all tests and top level run.sh accept --builddir and --srcdir command line options * functions.sh modified to use $top_builddir/tests for output files Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fe74e6856..e22dad339 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,6 +47,7 @@ INSTALL_EXEC_HOOKS =
UNINSTALL_HOOKS =
INSTALL_DATA_HOOKS =
CLEAN_LOCALS =
+CHECK_LOCALS =
EXTRA_DIST = man/ru/ddate.1
CLEANFILES =
@@ -153,3 +154,5 @@ uninstall-hook: $(UNINSTALL_HOOKS)
install-data-hook: $(INSTALL_DATA_HOOKS)
clean-local: $(CLEAN_LOCALS)
+
+check-local: $(CHECK_LOCALS)