summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSami Kerola2011-05-21 15:02:10 +0200
committerKarel Zak2011-05-26 15:04:01 +0200
commit2b85ab880d4fff8addb2deac4c25223c7973976e (patch)
treed929dd49c0994ba8f83a8f9c89ed2ecc0e5928e0 /Makefile.am
parentbuild-sys: stop building line(1) by default (diff)
downloadkernel-qcow2-util-linux-2b85ab880d4fff8addb2deac4c25223c7973976e.tar.gz
kernel-qcow2-util-linux-2b85ab880d4fff8addb2deac4c25223c7973976e.tar.xz
kernel-qcow2-util-linux-2b85ab880d4fff8addb2deac4c25223c7973976e.zip
build-sys: use AUTOMAKE_OPTIONS = gnu
The change will cause make dist to have INSTALL file from automake release, which hopefully is more up to date than manually maintained version. The gnu option will also require ChangeLog to be present, and without doubts no-one wants to maintain that manually. I added file to reference link to internet git repository view. At the time of make dist current tag is added to the ChangeLog reference which will make release to point exactly to the point where changes ended. Minor drawback is that untagged make dist releases will contain a broken link in ChangeLog. Signed-off-by: Sami Kerola <kerolasa@iki.fi>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 865ee091b..5e2029473 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -57,6 +57,7 @@ if BUILD_FSCK
SUBDIRS += fsck
endif
+AUTOMAKE_OPTIONS = gnu
ACLOCAL_AMFLAGS = -I m4
EXTRA_DIST = \
@@ -75,6 +76,8 @@ EXTRA_DIST = \
# tarball, and never in a checked-out repository.
dist-hook:
echo $(VERSION) > $(distdir)/.tarball-version
+# Set ChangeLog tag reference.
+ sed -i "s/log/log;h=$(VERSION)/" $(distdir)/ChangeLog
distclean-local:
-find . -name \*~ -o -name \*.orig -o -name \*.rej | xargs rm -f