summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2012-05-23 09:37:38 +0200
committerKarel Zak2012-06-26 17:37:37 +0200
commit3632ce21b7c3f9c564c3c0f962c4840719f1c2d6 (patch)
tree4afb5a9998488c7f98cc49e5bf7b91dda672dddf /Makefile.am
parentbuild-sys: convert schedutils/ to module (diff)
downloadkernel-qcow2-util-linux-3632ce21b7c3f9c564c3c0f962c4840719f1c2d6.tar.gz
kernel-qcow2-util-linux-3632ce21b7c3f9c564c3c0f962c4840719f1c2d6.tar.xz
kernel-qcow2-util-linux-3632ce21b7c3f9c564c3c0f962c4840719f1c2d6.zip
build-sys: convert libuuid/ to module
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 14 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 8e9171a61..cc23b7a76 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,15 +1,23 @@
include $(top_srcdir)/config/include-Makefile.am
+pkgconfigdir = $(usrlib_execdir)/pkgconfig
+
dist_noinst_HEADERS =
noinst_PROGRAMS =
usrbin_exec_PROGRAMS =
dist_man_MANS =
+man_MANS =
+pkgconfig_DATA =
+usrlib_exec_LTLIBRARIES =
-SHLIBS_DIRS =
+INSTALL_EXEC_HOOKS =
+UNINSTALL_HOOKS =
-if BUILD_LIBUUID
-SHLIBS_DIRS += libuuid
-endif
+EXTRA_DIST =
+CLEANFILES =
+
+
+SHLIBS_DIRS =
if BUILD_LIBBLKID
SHLIBS_DIRS += libblkid
@@ -55,7 +63,7 @@ endif
AUTOMAKE_OPTIONS = gnu
ACLOCAL_AMFLAGS = -I m4
-EXTRA_DIST = \
+EXTRA_DIST += \
.version \
autogen.sh \
Documentation \
@@ -66,6 +74,7 @@ EXTRA_DIST = \
include include/Makemodule.am
include lib/Makemodule.am
include schedutils/Makemodule.am
+include libuuid/Makemodule.am
# Arrange so that .tarball-version appears only in the distribution