summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSami Kerola2011-03-31 22:10:07 +0200
committerKarel Zak2011-04-05 16:34:00 +0200
commit38c75b59e357c03877ccfc377c6d4400c9610c93 (patch)
tree3c034a3fe4a01b08f38fb54f8136e6aaad7c7131 /Makefile.am
parentlibmount: fix parsing of mountinfo from 2.6.39 (diff)
downloadkernel-qcow2-util-linux-38c75b59e357c03877ccfc377c6d4400c9610c93.tar.gz
kernel-qcow2-util-linux-38c75b59e357c03877ccfc377c6d4400c9610c93.tar.xz
kernel-qcow2-util-linux-38c75b59e357c03877ccfc377c6d4400c9610c93.zip
build-sys: use git-version-gen to distinct git and release versions
The script is copied as is from gnulib. [kzak@redhat.com: - generate .tarball-version and .version files in top level Makefile.am - delete autom4te.cache in autogen.sh] Signed-off-by: Sami Kerola <kerolasa@iki.fi> Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index edf2dbfae..865ee091b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,6 +60,7 @@ endif
ACLOCAL_AMFLAGS = -I m4
EXTRA_DIST = \
+ .version \
autogen.sh \
README.devel \
README.licensing \
@@ -70,6 +71,10 @@ EXTRA_DIST = \
tools \
docs
+# Arrange so that .tarball-version appears only in the distribution
+# tarball, and never in a checked-out repository.
+dist-hook:
+ echo $(VERSION) > $(distdir)/.tarball-version
distclean-local:
-find . -name \*~ -o -name \*.orig -o -name \*.rej | xargs rm -f
@@ -93,3 +98,9 @@ ENABLE_ALL = --enable-static-programs \
--enable-login-utils --enable-write --enable-arch --enable-mount
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --disable-use-tty-group $(ENABLE_ALL)
+
+
+BUILT_SOURCES = .version
+.version:
+ echo $(VERSION) > $@-t && mv $@-t $@
+