summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2008-11-26 12:42:35 +0100
committerKarel Zak2008-11-26 12:59:29 +0100
commit44e293d65c78b8a97c22be4e94657bd5fb2b9bfd (patch)
tree03663675b0f07d225400b07b58735b00488b7b67 /Makefile.am
parentfdisk: fix man page typo (diff)
downloadkernel-qcow2-util-linux-44e293d65c78b8a97c22be4e94657bd5fb2b9bfd.tar.gz
kernel-qcow2-util-linux-44e293d65c78b8a97c22be4e94657bd5fb2b9bfd.tar.xz
kernel-qcow2-util-linux-44e293d65c78b8a97c22be4e94657bd5fb2b9bfd.zip
tools: add checkincludes.pl (from linux kernel)
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b78e8a77a..fefff76f5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,6 +14,10 @@ SUBDIRS = \
text-utils \
tests
+
+RCS_FIND_IGNORE := \( -name SCCS -o -name BitKeeper -o -name .svn -o \
+ -name CVS -o -name .pc -o -name .hg -o -name .git \) -prune -o
+
if LINUX
SUBDIRS += \
hwclock \
@@ -42,6 +46,13 @@ distclean-local:
-find . -name \*~ -o -name \*.orig -o -name \*.rej | xargs rm -f
rm -rf autom4te.cache
+
+checkincludes:
+ -find * $(RCS_FIND_IGNORE) \
+ -name '*.[hcS]' -type f -print | sort -u \
+ | xargs $(top_srcdir)/tools/checkincludes.pl
+
+
ENABLE_ALL = --enable-static-programs \
--enable-elvtune --enable-init --enable-kill --enable-last \
--enable-mesg --enable-partx --enable-raw --enable-rdev --enable-reset \