summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2019-04-24 18:02:39 +0200
committerKarel Zak2019-04-24 18:02:39 +0200
commit58354269eb9ab3b1963b2d56294393a3d02db712 (patch)
treedd4bd43ccef98c633c6ffb2078f2fbce265953f1 /Makefile.am
parentsu: make comment more friedly to 'make checkxalloc' (diff)
downloadkernel-qcow2-util-linux-58354269eb9ab3b1963b2d56294393a3d02db712.tar.gz
kernel-qcow2-util-linux-58354269eb9ab3b1963b2d56294393a3d02db712.tar.xz
kernel-qcow2-util-linux-58354269eb9ab3b1963b2d56294393a3d02db712.zip
build-sys: add 'make checklibdoc'
Let's to be sure that all libs API symbols are documented. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0ae085d9a..adf87804b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -187,6 +187,19 @@ checkusage:
@ $(top_srcdir)/tools/checkusage.sh \
$(bin_PROGRAMS) $(sbin_PROGRAMS) \
$(usrbin_exec_PROGRAMS) $(usrsbin_exec_PROGRAMS)
+checklibdoc:
+ @ $(top_srcdir)/tools/checklibdocs.sh \
+ $(top_srcdir)/libmount/src/libmount.sym \
+ $(top_srcdir)/libmount/docs/libmount-sections.txt
+ @ $(top_srcdir)/tools/checklibdocs.sh \
+ $(top_srcdir)/libfdisk/src/libfdisk.sym \
+ $(top_srcdir)/libfdisk/docs/libfdisk-sections.txt
+ @ $(top_srcdir)/tools/checklibdocs.sh \
+ $(top_srcdir)/libsmartcols/src/libsmartcols.sym \
+ $(top_srcdir)/libsmartcols/docs/libsmartcols-sections.txt
+ @ $(top_srcdir)/tools/checklibdocs.sh \
+ $(top_srcdir)/libblkid/src/libblkid.sym \
+ $(top_srcdir)/libblkid/docs/libblkid-sections.txt
DISTCHECK_CONFIGURE_FLAGS = \
--disable-use-tty-group \