summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlon Bar-Lev2008-11-14 17:40:25 +0100
committerKarel Zak2008-11-19 12:40:06 +0100
commit7177d32ecfc2c1404e6067a573362af3324840fb (patch)
tree6b8f3c9f3ed30c28d9ebe49a0b09e3041eb6928a /Makefile.am
parentpivot_root: clean up (diff)
downloadkernel-qcow2-util-linux-7177d32ecfc2c1404e6067a573362af3324840fb.tar.gz
kernel-qcow2-util-linux-7177d32ecfc2c1404e6067a573362af3324840fb.tar.xz
kernel-qcow2-util-linux-7177d32ecfc2c1404e6067a573362af3324840fb.zip
build-sys: add --disable-mount
I use busybox for most of the utilities, still lacks a few that I wish to use from util-linux... So mount comes from busybox. And during the cross compile I don't want to compile the mount dependencies only to make the configure script happy... Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com> Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a643d4617..b78e8a77a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,10 +17,13 @@ SUBDIRS = \
if LINUX
SUBDIRS += \
hwclock \
- mount \
partx
endif
+if BUILD_MOUNT
+SUBDIRS += mount
+endif
+
ACLOCAL_AMFLAGS = -I m4
EXTRA_DIST = \
@@ -42,5 +45,5 @@ distclean-local:
ENABLE_ALL = --enable-static-programs \
--enable-elvtune --enable-init --enable-kill --enable-last \
--enable-mesg --enable-partx --enable-raw --enable-rdev --enable-reset \
- --enable-login-utils --enable-write --enable-arch
+ --enable-login-utils --enable-write --enable-arch --enable-mount
DISTCHECK_CONFIGURE_FLAGS = --disable-use-tty-group $(ENABLE_ALL)