summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2012-01-19 10:32:32 +0100
committerKarel Zak2012-01-19 10:32:32 +0100
commit748c010f070e96ff397a65e2338ae58125f085c0 (patch)
treeb43048a724e7c005124c0a328b9b9f7691c5692b /Makefile.am
parentbuild-sys: add changelog target (diff)
downloadkernel-qcow2-util-linux-748c010f070e96ff397a65e2338ae58125f085c0.tar.gz
kernel-qcow2-util-linux-748c010f070e96ff397a65e2338ae58125f085c0.tar.xz
kernel-qcow2-util-linux-748c010f070e96ff397a65e2338ae58125f085c0.zip
build-sys: improve changelog target
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 032555926..7bd0b37c4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -100,8 +100,9 @@ BUILT_SOURCES = .version
echo $(VERSION) > $@-t && mv $@-t $@
CHANGELOG_FILE = v$(VERSION)-ChangeLog
-changelog:
- if test "x$$PREVIOUS_VERSION" == "x"; then \
+
+$(CHANGELOG_FILE):
+ @ if test "x$$PREVIOUS_VERSION" == "x"; then \
echo "Usage make changelog PREVIOUS_VERSION=<version>"; \
exit 1; \
fi
@@ -110,3 +111,6 @@ changelog:
@ echo >> $(CHANGELOG_FILE)
$(AM_V_GEN) git log --stat v$(PREVIOUS_VERSION)..HEAD >> $(CHANGELOG_FILE)
+changelog: $(CHANGELOG_FILE)
+
+