summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2012-07-09 16:44:25 +0200
committerKarel Zak2012-07-09 16:44:25 +0200
commit7bce71a3f9e4dc0a2cae527f383f23367eca5c1a (patch)
treec2a8d97e31fa81d693e632a4fe0bf0eb1ce13760 /Makefile.am
parentbuild-sys: always use default $(LDADD) (diff)
downloadkernel-qcow2-util-linux-7bce71a3f9e4dc0a2cae527f383f23367eca5c1a.tar.gz
kernel-qcow2-util-linux-7bce71a3f9e4dc0a2cae527f383f23367eca5c1a.tar.xz
kernel-qcow2-util-linux-7bce71a3f9e4dc0a2cae527f383f23367eca5c1a.zip
build-sys: support separate libintl
Addresses: https://github.com/karelzak/util-linux/pull/13 Reported-by: Ben Walton <bwalton@artsci.utoronto.ca> Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8b8368b2d..be5dd09fe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,6 +6,11 @@ AM_CPPFLAGS = \
AM_CFLAGS = -fsigned-char $(WARN_CFLAGS)
AM_LDFLAGS =
+# Add gettext stuff to the global LDADD for systems with separate libintl
+# library. The LTLIBINTL is generated by AM_GNU_GETTEXT macro.
+#
+LDADD = $(LTLIBINTL)
+
# Automake (at least up to 1.10) mishandles dist_man_MANS inside conditionals.
# Unlike with other dist primaries, the files are not distributed if the
# conditional is false.