summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2007-01-03 22:20:44 +0100
committerKarel Zak2007-01-03 22:20:44 +0100
commit8eeb575c0d4a0a7af62615829ae99fed4ee3c08c (patch)
tree2a947d2f207c9fd4cd1b49ce242b81d7422b9502 /Makefile.am
parentImported from util-linux-2.13-pre7 tarball. (diff)
downloadkernel-qcow2-util-linux-8eeb575c0d4a0a7af62615829ae99fed4ee3c08c.tar.gz
kernel-qcow2-util-linux-8eeb575c0d4a0a7af62615829ae99fed4ee3c08c.tar.xz
kernel-qcow2-util-linux-8eeb575c0d4a0a7af62615829ae99fed4ee3c08c.zip
build-sys: remove generated autotools stuff from git
The generated autotools stuff shouldn't be maintained by SCM. After check out from git use ./autogen.sh. For more details see README.devel. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index b46010bb4..5c3564e96 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,7 @@
include $(top_srcdir)/config/include-Makefile.am
SUBDIRS = lib \
+ include \
disk-utils \
fdisk \
getopt \
@@ -16,8 +17,17 @@ SUBDIRS = lib \
ACLOCAL_AMFLAGS = -I m4
-EXTRA_DIST = config/mkinstalldirs config/include-Makefile.am
+EXTRA_DIST = config/include-Makefile.am \
+ autogen.sh
distclean-local:
- -for i in `find . -name \*~ -o -name \*.orig -o -name \*.rej`; do rm $$i; done
+ -find . \( -name \*~ -o -name \*.orig -o -name \*.rej \) -exec rm -f {} \;
rm -rf autom4te.cache
+
+mrproper: distclean
+ -find -name Makefile.in -exec rm -f {} \;
+ rm -f configure ABOUT-NLS
+ rm -rf m4
+ cd po; rm -f `cat .gitignore`; cd ..
+ cd config; rm -f `cat ../.gitignore`; cd ..
+