summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2013-04-05 14:14:28 +0200
committerKarel Zak2013-04-05 14:14:28 +0200
commitaead7c7e690ab019e0706f228a226b8c17eeab38 (patch)
tree618a83c7e7e16321089eff1ab1f5c268b0561bea /Makefile.am
parentlogger: make local sockets to try both stream and datagram (diff)
parentbash-completion: add completion files to Makefile.am (diff)
downloadkernel-qcow2-util-linux-aead7c7e690ab019e0706f228a226b8c17eeab38.tar.gz
kernel-qcow2-util-linux-aead7c7e690ab019e0706f228a226b8c17eeab38.tar.xz
kernel-qcow2-util-linux-aead7c7e690ab019e0706f228a226b8c17eeab38.zip
Merge branch 'shell-completion' of git://github.com/kerolasa/lelux-utiliteetit
* 'shell-completion' of git://github.com/kerolasa/lelux-utiliteetit: bash-completion: add completion files to Makefile.am bash-completion: text-utils bash-completion: term-utils bash-completion: sys-utils bash-completion: schedutils bash-completion: misc-utils bash-completion: login-utils bash-completion: fdisks bash-completion: disk-utils bash-completion: add bash completetion configure option
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3afcad16d..b963af941 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,6 +27,8 @@ ul_libfdisk_incdir = $(top_srcdir)/libfdisk/src
pkgconfigdir = $(usrlib_execdir)/pkgconfig
+bashcompletiondir = @bashcompletiondir@
+
dist_noinst_HEADERS =
noinst_PROGRAMS =
noinst_LTLIBRARIES =
@@ -87,6 +89,8 @@ include misc-utils/Makemodule.am
include disk-utils/Makemodule.am
include fdisks/Makemodule.am
+include shell-completion/Makemodule.am
+
include tests/Makemodule.am
#
@@ -158,6 +162,7 @@ checkdecl:
ENABLE_ALL = --enable-static-programs --enable-most-builds
DISTCHECK_CONFIGURE_FLAGS = --disable-use-tty-group \
--disable-silent-rules $(ENABLE_ALL) \
+ --with-bashcompletiondir=$$dc_install_base/$(bashcompletiondir) \
--with-systemdsystemunitdir=$$dc_install_base/$(systemdsystemunitdir)