summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2012-06-13 11:59:29 +0200
committerKarel Zak2012-06-13 11:59:29 +0200
commitb5c6f48631ca3eb66a76a54faa2cd82c9140a917 (patch)
tree99ff14d125a6b2a65b93605e62322940c63949c8 /Makefile.am
parentlibblkid: trust in udev symlinks, don't verify (diff)
downloadkernel-qcow2-util-linux-b5c6f48631ca3eb66a76a54faa2cd82c9140a917.tar.gz
kernel-qcow2-util-linux-b5c6f48631ca3eb66a76a54faa2cd82c9140a917.tar.xz
kernel-qcow2-util-linux-b5c6f48631ca3eb66a76a54faa2cd82c9140a917.zip
tools: add small and stupid script to check HAVE_DECL_
use 'make checkdecl' to run the script Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 055cc4d8b..0f6414189 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -90,6 +90,9 @@ checkmans:
checkxalloc:
@ $(top_srcdir)/tools/checkxalloc.sh
+checkdecl:
+ @ $(top_srcdir)/tools/checkdecl.sh
+
ENABLE_ALL = --enable-static-programs --enable-most-builds
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --disable-use-tty-group \
--disable-silent-rules $(ENABLE_ALL) \