summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2007-02-08 12:38:25 +0100
committerKarel Zak2007-02-08 12:38:25 +0100
commitb8d1314dc6ceeb998632102d5f93cda5e2548f8d (patch)
treecfe10b664e00613db5fc2d6bd4b585600e3cdcee /Makefile.am
parentmkswap: add regression test (diff)
downloadkernel-qcow2-util-linux-b8d1314dc6ceeb998632102d5f93cda5e2548f8d.tar.gz
kernel-qcow2-util-linux-b8d1314dc6ceeb998632102d5f93cda5e2548f8d.tar.xz
kernel-qcow2-util-linux-b8d1314dc6ceeb998632102d5f93cda5e2548f8d.zip
build-sys: fix README filenames and add missing files to EXTRA_DISTs
Also, the patch makes "make mrproper" more robust. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 13 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index b5293e2f9..b1ab4e240 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,19 +20,25 @@ ACLOCAL_AMFLAGS = -I m4
EXTRA_DIST = config/include-Makefile.am \
autogen.sh \
- licenses/COPYING.GPL \
- licenses/COPYING.UCB
+ README.* \
+ licenses/* \
+ example.files/* \
+ po/Makevars.template \
+ po/update-potfiles
+
distclean-local:
-find . \( -name \*~ -o -name \*.orig -o -name \*.rej \) -exec rm -f {} \;
rm -rf autom4te.cache
mrproper: distclean
- -find -name Makefile.in -exec rm -f {} \;
- rm -f configure ABOUT-NLS
- rm -rf m4
- cd po; rm -f `cat .gitignore`; cd ..
- cd config; rm -f `cat ../.gitignore`; cd ..
+ if [ -f ".gitignore" ]; then \
+ find -name Makefile.in -exec rm -f {} \; ; \
+ rm -f configure ABOUT-NLS ; \
+ rm -rf m4 ; \
+ cd config; rm -f `cat ../.gitignore`; cd .. ; \
+ cd po; rm -f `cat .gitignore`; cd .. ; \
+ fi
# The automake is very stupid for work with man pages. The files from man_MANS are
# not included to the distribution. A solution is use dist_man_MANS or