summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDiego Elio 'Flameeyes' Pettenò2010-07-28 22:40:04 +0200
committerKarel Zak2010-07-29 17:48:01 +0200
commitebc83db1a1d123a74da7e8bd07b281ab17e18ed6 (patch)
treeff9e462c491a29bfe882a40ed6e3a675f6e73ca5 /Makefile.am
parentbuild-sys: drop the getsize test out of Makefile.am (diff)
downloadkernel-qcow2-util-linux-ebc83db1a1d123a74da7e8bd07b281ab17e18ed6.tar.gz
kernel-qcow2-util-linux-ebc83db1a1d123a74da7e8bd07b281ab17e18ed6.tar.xz
kernel-qcow2-util-linux-ebc83db1a1d123a74da7e8bd07b281ab17e18ed6.zip
build-sys: drop shlibs/Makefile.am that only adds SUBDIRS
The same effect is gotten by changing SUBDIRS in the top-level Makefile.am.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f332510a3..c489665f5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,12 +1,26 @@
include $(top_srcdir)/config/include-Makefile.am
+SHLIBS_DIRS =
+
+if BUILD_LIBUUID
+SHLIBS_DIRS += shlibs/uuid
+endif
+
+if BUILD_LIBBLKID
+SHLIBS_DIRS += shlibs/blkid
+endif
+
+if BUILD_LIBMOUNT
+SHLIBS_DIRS += shlibs/mount
+endif
+
SUBDIRS = \
include \
disk-utils \
fdisk \
getopt \
lib \
- shlibs \
+ $(SHLIBS_DIRS) \
login-utils \
misc-utils \
po \