summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRuediger Meier2014-06-02 23:59:07 +0200
committerRuediger Meier2014-06-03 17:00:26 +0200
commitf339d2a5c291a9e1cfa547d56c58486f1db0fc49 (patch)
tree83196fd74e5224269047397d97a7bbd05bdd6193 /Makefile.am
parentbuild-sys: use automake's PYTHON primary for __init__.py (diff)
downloadkernel-qcow2-util-linux-f339d2a5c291a9e1cfa547d56c58486f1db0fc49.tar.gz
kernel-qcow2-util-linux-f339d2a5c291a9e1cfa547d56c58486f1db0fc49.tar.xz
kernel-qcow2-util-linux-f339d2a5c291a9e1cfa547d56c58486f1db0fc49.zip
build-sys: restore make distcheck's configure flags
They got lost with --enable-most-builds in 08b1c219. Note additionally we add --enable-gtk-doc but don't add --with-systemd because there are still many systems where systemd is not available. Signed-off-by: Ruediger Meier <ruediger.meier@ga-group.nl>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 7d0176547..73ec1e2cb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -161,12 +161,15 @@ checkxalloc:
checkdecl:
@ $(top_srcdir)/tools/checkdecl.sh
-ENABLE_ALL = --enable-static-programs --enable-most-builds
-DISTCHECK_CONFIGURE_FLAGS = --disable-use-tty-group \
- --disable-silent-rules $(ENABLE_ALL) \
- --with-bashcompletiondir=$$dc_install_base/$(bashcompletiondir) \
- --with-systemdsystemunitdir=$$dc_install_base/$(systemdsystemunitdir)
-
+DISTCHECK_CONFIGURE_FLAGS = \
+ --disable-use-tty-group \
+ --disable-silent-rules \
+ --enable-all-programs \
+ --enable-static-programs \
+ --enable-gtk-doc \
+ --with-python \
+ --with-bashcompletiondir=$$dc_install_base/$(bashcompletiondir) \
+ --with-systemdsystemunitdir=$$dc_install_base/$(systemdsystemunitdir)
BUILT_SOURCES = .version
.version: