summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2011-06-21 11:46:36 +0200
committerKarel Zak2011-06-21 11:46:36 +0200
commit0164c24595bd4209ab7b668fec34f5cdcdd1d5eb (patch)
tree1ec58f53eea5c35dd9890fca81b9a537fb2e9c58 /configure.ac
parentdocs: update TODO file (diff)
downloadkernel-qcow2-util-linux-0164c24595bd4209ab7b668fec34f5cdcdd1d5eb.tar.gz
kernel-qcow2-util-linux-0164c24595bd4209ab7b668fec34f5cdcdd1d5eb.tar.xz
kernel-qcow2-util-linux-0164c24595bd4209ab7b668fec34f5cdcdd1d5eb.zip
mountpoint: add new command
This is libmount based re-implementation of the mountpoint(1) command. The original implementation is maintained in sysvinit suite. The mountpoint(1) in util-linux is not enabled by default (for now) -- use --enable-mountpoint to enable the util. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 52eade9e1..a02b5e31f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -483,6 +483,17 @@ esac
AM_CONDITIONAL(BUILD_LIBMOUNT_MOUNT, test "x$enable_libmount_mount" = xyes)
+AC_ARG_ENABLE([mountpoint],
+ AS_HELP_STRING([--enable-mountpoint], [build mountpoint]),
+ [], enable_mountpoint=no
+)
+case "$enable_libmount:$enable_mountpoint" in
+no:yes)
+ AC_MSG_ERROR([cannot enable mountpoint when libmount is disabled]) ;;
+esac
+AM_CONDITIONAL(BUILD_MOUNTPOINT, test "x$enable_mountpoint" = xyes)
+
+
UTIL_CHECK_LIB(util, openpty)
UTIL_CHECK_LIB(termcap, tgetnum)