summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2013-08-27 10:02:04 +0200
committerKarel Zak2013-08-27 11:49:01 +0200
commit03d00d495f3b505d9cae967c629fb38aca301e01 (patch)
tree3433ad37aa6b694d4933668b1cdb9c602571be6a /configure.ac
parenttests: minor changes to make tests more portable (diff)
downloadkernel-qcow2-util-linux-03d00d495f3b505d9cae967c629fb38aca301e01.tar.gz
kernel-qcow2-util-linux-03d00d495f3b505d9cae967c629fb38aca301e01.tar.xz
kernel-qcow2-util-linux-03d00d495f3b505d9cae967c629fb38aca301e01.zip
build-sys: add CFLAGS and LDFLAGS for daemons and shared libs
This is necessary for paranoid security guys who believe that things like "-Wl,-z,relro" or "-Wl,-z,bind_now" is a way how to make the world a safer place... Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 982606eb6..a0a72fd29 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1473,6 +1473,16 @@ AC_ARG_VAR([SUID_CFLAGS],
AC_ARG_VAR([SUID_LDFLAGS],
[LDFLAGS used for binaries which are usually with the suid bit])
+AC_ARG_VAR([DAEMON_CFLAGS],
+ [CFLAGS used for binaries which are usually executed as daemons])
+AC_ARG_VAR([DAEMON_LDFLAGS],
+ [LDFLAGS used for binaries which are usually executed as daemons])
+
+AC_ARG_VAR([SOLIB_CFLAGS],
+ [CFLAGS used for shared libraries])
+AC_ARG_VAR([SOLIB_LDFLAGS],
+ [LDFLAGS used for shared libraries])
+
LIBS=""