summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2014-08-01 12:09:55 +0200
committerKarel Zak2014-08-01 12:09:55 +0200
commit0624d8406b8e8e64f7a1c6dcea7af648d99ef08d (patch)
treea549ba1c86c02df97df851c5bffb713d37ca743a /configure.ac
parentlib/ismounted: make it more compatible with lsblk output (diff)
downloadkernel-qcow2-util-linux-0624d8406b8e8e64f7a1c6dcea7af648d99ef08d.tar.gz
kernel-qcow2-util-linux-0624d8406b8e8e64f7a1c6dcea7af648d99ef08d.tar.xz
kernel-qcow2-util-linux-0624d8406b8e8e64f7a1c6dcea7af648d99ef08d.zip
zrmactl: add new command to control /dev/zramN devices
Co-Author: Timofey Titovets <nefelim4ag@gmail.com> Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c6c74da02..948710e19 100644
--- a/configure.ac
+++ b/configure.ac
@@ -861,6 +861,14 @@ UL_REQUIRES_LINUX([losetup])
UL_REQUIRES_BUILD([losetup], [libsmartcols])
AM_CONDITIONAL([BUILD_LOSETUP], [test "x$build_losetup" = xyes])
+AC_ARG_ENABLE([zramctl],
+ AS_HELP_STRING([--disable-zramctl], [do not build zramctl]),
+ [], [UL_DEFAULT_ENABLE([zramctl], [check])]
+)
+UL_BUILD_INIT([zramctl])
+UL_REQUIRES_LINUX([zramctl])
+UL_REQUIRES_BUILD([zramctl], [libsmartcols])
+AM_CONDITIONAL([BUILD_ZRAMCTL], [test "x$build_zramctl" = xyes])
AC_ARG_ENABLE([fsck],
AS_HELP_STRING([--disable-fsck], [do not build fsck]),