summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2011-10-27 14:44:30 +0200
committerKarel Zak2011-11-03 12:32:50 +0100
commit09734b00f87d94514911724bd7466b326201d4f2 (patch)
treefa15606f43a6d0a9992b8b850007f676e8b8f662 /configure.ac
parentbuild-sys: cleanup BUILD_{LS,CH}CPU (diff)
downloadkernel-qcow2-util-linux-09734b00f87d94514911724bd7466b326201d4f2.tar.gz
kernel-qcow2-util-linux-09734b00f87d94514911724bd7466b326201d4f2.tar.xz
kernel-qcow2-util-linux-09734b00f87d94514911724bd7466b326201d4f2.zip
build-sys: move gettext check before --enable-*
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 9 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 411405e22..6bc46b623 100644
--- a/configure.ac
+++ b/configure.ac
@@ -105,6 +105,15 @@ AM_CONDITIONAL([LINUX], test "x$linux_os" = xyes)
AC_SYS_LARGEFILE
+AM_GNU_GETTEXT_VERSION([0.14.1])
+AM_GNU_GETTEXT([external])
+if test -d "$srcdir/po"
+then
+ ALL_LINGUAS=`cd $srcdir/po > /dev/null && echo *.po | sed 's/\.po//g'`
+else
+ ALL_LINGUAS="af am ar as be bg bn_IN bn ca cs cy da de el en_GB es et eu_ES fa fi fr gl gu he hi hr hu hy id is it ja ka kn ko ku lo lt lv mk ml mr ms my nb nl nn no nso or pa pl pt_BR pt ro ru si sk sl sq sr@Latn sr sv ta te th tr uk ur vi zh_CN zh_TW zu"
+fi
+
AC_CHECK_HEADERS([linux/compiler.h linux/blkpg.h linux/major.h], [], [], [
#ifdef HAVE_LINUX_COMPILER_H
#include <linux/compiler.h>
@@ -481,14 +490,6 @@ AM_CONDITIONAL(BUILD_MOUNTPOINT, test "x$build_mountpoint" = xyes)
UL_CHECK_LIB(util, openpty)
UL_CHECK_LIB(termcap, tgetnum)
-AM_GNU_GETTEXT_VERSION([0.14.1])
-AM_GNU_GETTEXT([external])
-if test -d "$srcdir/po"
-then
- ALL_LINGUAS=`cd $srcdir/po > /dev/null && echo *.po | sed 's/\.po//g'`
-else
- ALL_LINGUAS="af am ar as be bg bn_IN bn ca cs cy da de el en_GB es et eu_ES fa fi fr gl gu he hi hr hu hy id is it ja ka kn ko ku lo lt lv mk ml mr ms my nb nl nn no nso or pa pl pt_BR pt ro ru si sk sl sq sr@Latn sr sv ta te th tr uk ur vi zh_CN zh_TW zu"
-fi
AC_ARG_WITH([ncurses],
AS_HELP_STRING([--with-ncurses], [build with non-wide ncurses, default is wide version