summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSami Kerola2012-06-10 16:37:11 +0200
committerSami Kerola2012-06-11 19:51:35 +0200
commit0e9b73d3fb5e3c7a5146af65e119e297dcf75487 (patch)
tree8528c62980a043ea589484d8aa518aa91a96963f /configure.ac
parentinclude: fix spurious list.h warnings (diff)
downloadkernel-qcow2-util-linux-0e9b73d3fb5e3c7a5146af65e119e297dcf75487.tar.gz
kernel-qcow2-util-linux-0e9b73d3fb5e3c7a5146af65e119e297dcf75487.tar.xz
kernel-qcow2-util-linux-0e9b73d3fb5e3c7a5146af65e119e297dcf75487.zip
build: fix redundant redeclaration warnings
env.c:24:15: warning: redundant redeclaration of 'environ' [-Wredundant-decls] su.c:81:15: warning: redundant redeclaration of 'environ' [-Wredundant-decls] fstab.c:581:14: warning: redundant redeclaration of 'strsignal' [-Wredundant-decls] kill.h:1:13: note: previous declaration of 'get_pids' was here kill.c:152:13: warning: redundant redeclaration of 'get_pids' [-Wredundant-decls] kill.c:142:5: warning: redundant redeclaration of 'main' [-Wredundant-decls] getopt.c:89:5: warning: redundant redeclaration of 'main' [-Wredundant-decls] agetty.c:536:15: warning: redundant redeclaration of 'optarg' [-Wredundant-decls] agetty.c:537:13: warning: redundant redeclaration of 'optind' [-Wredundant-decls] script.c:161:13: warning: redundant redeclaration of 'optind' [-Wredundant-decls] wall.c:96:13: warning: redundant redeclaration of 'optind' [-Wredundant-decls] libmount.h:362:26: note: previous declaration of 'mnt_update_get_fs' was here libmount.h:454:26: note: previous declaration of 'mnt_context_get_fs' was here mountP.h:383:26: warning: redundant redeclaration of 'mnt_context_get_fs' [-Wredundant-decls] mountP.h:398:26: warning: redundant redeclaration of 'mnt_update_get_fs' [-Wredundant-decls] Signed-off-by: Sami Kerola <kerolasa@iki.fi>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2280e7e51..0669f0ab5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -262,6 +262,16 @@ AC_CHECK_DECL([lseek64],
#define _LARGEFILE64_SOURCE
#include <unistd.h>])
+AC_CHECK_DECL([environ],
+ [AC_DEFINE(HAVE_ENVIRON_DECL, 1,
+ [Define to 1 if have **environ prototype])],
+)
+
+AC_CHECK_DECL([strsignal],
+ [AC_DEFINE(HAVE_STRSIGNAL_DECL, 1,
+ [Define to 1 if have strsignal function prototype])],
+)
+
AC_CHECK_FUNCS([ \
__fpending \
__secure_getenv \