summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSami Kerola2012-12-16 11:43:56 +0100
committerKarel Zak2012-12-19 11:38:48 +0100
commit1342ffcbeb0dbad6ec12026f1dad27a26d27248f (patch)
tree02a42b5c4e5bef63408581c8e32826944beaabf1 /configure.ac
parentmore: remove unnecessary variable (diff)
downloadkernel-qcow2-util-linux-1342ffcbeb0dbad6ec12026f1dad27a26d27248f.tar.gz
kernel-qcow2-util-linux-1342ffcbeb0dbad6ec12026f1dad27a26d27248f.tar.xz
kernel-qcow2-util-linux-1342ffcbeb0dbad6ec12026f1dad27a26d27248f.zip
tunelp: deprecation: remove command from default build
It is difficult to think think tunelp command being in use a lot. Signed-off-by: Sami Kerola <kerolasa@iki.fi>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c0783056c..9c08fc0e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -671,6 +671,7 @@ AC_ARG_ENABLE([most-builds],
if test "x$enable_most_builds" = xyes; then
enable_arch=check
enable_elvtune=check
+ enable_tunelp=yes
enable_last=yes
enable_line=yes
enable_mesg=yes
@@ -989,6 +990,15 @@ UL_REQUIRES_LINUX([elvtune])
AM_CONDITIONAL(BUILD_ELVTUNE, test "x$build_elvtune" = xyes)
+AC_ARG_ENABLE([tunelp],
+ AS_HELP_STRING([--enable-tunelp], [build tunelp]),
+ [], enable_tunelp=no
+)
+UL_BUILD_INIT([tunelp])
+UL_REQUIRES_LINUX([tunelp])
+AM_CONDITIONAL(BUILD_TUNELP, test "x$build_tunelp" = xyes)
+
+
AC_ARG_ENABLE([kill],
AS_HELP_STRING([--disable-kill], [do not build kill]),
[], enable_kill=check