summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2016-01-20 12:44:27 +0100
committerKarel Zak2016-01-20 12:44:27 +0100
commit15167589fb40be9479e1afe261bea0bf23b33a83 (patch)
tree84c0298452ba82f0f0f122ee51eec3f5966d755e /configure.ac
parentchrt: make usage more readable (diff)
downloadkernel-qcow2-util-linux-15167589fb40be9479e1afe261bea0bf23b33a83.tar.gz
kernel-qcow2-util-linux-15167589fb40be9479e1afe261bea0bf23b33a83.tar.xz
kernel-qcow2-util-linux-15167589fb40be9479e1afe261bea0bf23b33a83.zip
chrt: use sched_setattr() if available
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 83b76ae1f..2c1ffbc05 100644
--- a/configure.ac
+++ b/configure.ac
@@ -359,6 +359,7 @@ AC_CHECK_FUNCS([ \
scandirat \
setresgid \
setresuid \
+ sched_setattr \
sigqueue \
srandom \
strnchr \
@@ -1776,6 +1777,10 @@ UL_BUILD_INIT([chrt], [check])
UL_REQUIRES_BUILD([chrt], [schedutils])
AM_CONDITIONAL([BUILD_CHRT], [test "x$build_chrt" = xyes])
+AS_IF([test "x$build_chrt" = xyes], [
+ UL_CHECK_SYSCALL([sched_setattr])
+])
+
AC_ARG_ENABLE([wall],
AS_HELP_STRING([--disable-wall], [do not build wall]),