summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStepan Kasal2007-05-15 20:46:24 +0200
committerKarel Zak2007-05-16 11:43:30 +0200
commit15a9b48cf5a8e33e0f64070ca190c6eda586f8b8 (patch)
tree56f2318b1c907bc42012b801116e1d76ac443bdf /configure.ac
parentbuild-sys: set DISTCHECK_CONFIGURE_FLAGS in top-level makefile (diff)
downloadkernel-qcow2-util-linux-15a9b48cf5a8e33e0f64070ca190c6eda586f8b8.tar.gz
kernel-qcow2-util-linux-15a9b48cf5a8e33e0f64070ca190c6eda586f8b8.tar.xz
kernel-qcow2-util-linux-15a9b48cf5a8e33e0f64070ca190c6eda586f8b8.zip
build-sys: --prefix defaults to /usr
Use prefix=/usr as the default setting. If prefix is /usr, make bindir and sbindir default to /bin and /sbin, respectively. Signed-off-by: Stepan Kasal <skasal@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a457cc130..b9e5a90d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,7 +8,21 @@ AM_INIT_AUTOMAKE([check-news -Wall foreign 1.9])
AC_CONFIG_SRCDIR(mount/mount.c)
-AC_PREFIX_DEFAULT(/)
+AC_PREFIX_DEFAULT([/usr])
+
+# Check whether exec_prefix=/usr:
+case $exec_prefix:$prefix in
+NONE:NONE | NONE:/usr | /usr:*)
+ AC_MSG_NOTICE([Default --exec-prefix detected.])
+ case $bindir in
+ '${exec_prefix}/bin') bindir=/bin
+ AC_MSG_NOTICE([ --bindir defaults to /bin]) ;;
+ esac
+ case $sbindir in
+ '${exec_prefix}/sbin') sbindir=/sbin
+ AC_MSG_NOTICE([ --sbindir defaults to /sbin]) ;;
+ esac ;;
+esac
AC_PROG_CC_STDC
AC_PROG_LIBTOOL