summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2016-06-08 12:03:15 +0200
committerKarel Zak2016-06-08 12:03:15 +0200
commit18dae5d87999d4e8fff4c0ee19b54a0b24ac61bb (patch)
tree20531663c385fcbbb441ea2f1912e56bf362ac04 /configure.ac
parentbuild-sys: cleanup --with-ncurses (diff)
downloadkernel-qcow2-util-linux-18dae5d87999d4e8fff4c0ee19b54a0b24ac61bb.tar.gz
kernel-qcow2-util-linux-18dae5d87999d4e8fff4c0ee19b54a0b24ac61bb.tar.xz
kernel-qcow2-util-linux-18dae5d87999d4e8fff4c0ee19b54a0b24ac61bb.zip
build-sys: clean up relation between ncurses[w] and wide-char support
* error if wide-char enabled/supported, but (non-wide) ncurses explicitly requested * disable ncurses at all if widechar enabled/supported, but ncursesw not found Reported-by: Stanislav Brabec <sbrabec@suse.cz> Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1844bdaee..c09a95c39 100644
--- a/configure.ac
+++ b/configure.ac
@@ -792,6 +792,14 @@ AC_ARG_WITH([ncurses],
[], [with_ncurses=auto]
)
have_ncurses=no
+
+AS_CASE([$with_ncurses:$build_widechar],
+ [yes:yes], [AC_MSG_ERROR([wide-char support enabled, but non-wide ncurses selects])])
+
+AS_CASE([$have_ncursesw:$with_ncurses:$build_widechar],
+ [no:auto:yes],[AC_MSG_WARN( [wide-char support enabled, ncursesw not found, force --without-ncurses])
+ with_ncurses=no])
+
AS_IF([test "x$have_ncursesw" = xno -a "x$with_ncurses" != xno ], [
PKG_CHECK_MODULES(NCURSES, [ncurses], [
have_ncurses=yes
@@ -2196,6 +2204,7 @@ AC_MSG_RESULT([
Bash completions: ${with_bashcompletiondir}
Systemd support: ${have_systemd}
Btrfs support: ${have_btrfs}
+ Wide-char support: ${build_widechar}
warnings: