summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Frysinger2007-08-26 13:22:56 +0200
committerKarel Zak2007-08-27 10:48:29 +0200
commit19a224ad6aaed8b4547b85255d8deae80e8336da (patch)
tree57ea59e53a911c9620299453b023710428ed7b46 /configure.ac
parentsetarch: add parisc/parisc64 support (diff)
downloadkernel-qcow2-util-linux-19a224ad6aaed8b4547b85255d8deae80e8336da.tar.gz
kernel-qcow2-util-linux-19a224ad6aaed8b4547b85255d8deae80e8336da.tar.xz
kernel-qcow2-util-linux-19a224ad6aaed8b4547b85255d8deae80e8336da.zip
taskset: check for existence of sched_getaffinity
Some architectures do no reliably provide sched_getaffinity, so make sure the define exists before we try using it. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 369237031..00157e2db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -197,6 +197,16 @@ int test = SYS_pivot_root;
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+#include <sys/syscall.h>
+#include <unistd.h>
+]], [[
+int test = SYS_sched_getaffinity;
+]])],
+[AM_CONDITIONAL(HAVE_SCHED_GETAFFINITY, true)],
+[AM_CONDITIONAL(HAVE_SCHED_GETAFFINITY, false)])
+
+
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <time.h>
#include <unistd.h>
]], [[