summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPetr Uzel2012-05-03 21:01:58 +0200
committerKarel Zak2012-05-04 15:14:16 +0200
commit1b68c37927c193d10195b7f1ba03f9b6e3ff389e (patch)
tree4f0414ff7cc9e136ee1060e0b9e9b63565f16043 /configure.ac
parentlibuuid: use EXIT_FAILURE (diff)
downloadkernel-qcow2-util-linux-1b68c37927c193d10195b7f1ba03f9b6e3ff389e.tar.gz
kernel-qcow2-util-linux-1b68c37927c193d10195b7f1ba03f9b6e3ff389e.tar.xz
kernel-qcow2-util-linux-1b68c37927c193d10195b7f1ba03f9b6e3ff389e.zip
uuidd: add systemd unit files
Add systemd unit files which use the socket activation mechanism of systemd. The uuidd deamon is started upon first request on the socket and quits after 1 minute of inactivity. Signed-off-by: Petr Uzel <petr.uzel@suse.cz>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8b80f388f..a1b1e9b7f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1142,6 +1142,16 @@ if test "x$enable_socket_activation" = xyes; then
AC_DEFINE(USE_SOCKET_ACTIVATION, 1, [Should uuidd support socket activation?])
fi
+AC_ARG_WITH([systemdsystemunitdir],
+ AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [directory for systemd service files]),
+ [], [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
+
+if test "x$with_systemdsystemunitdir" != "xno"; then
+ AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
+fi
+
+AM_CONDITIONAL(WITH_SYSTEMD, [test -n "$with_systemdsystemunitdir" -a "x$with_systemdsystemunitdir" != "xno" ])
+
AC_ARG_ENABLE([login-stat-mail],
AS_HELP_STRING([--enable-login-stat-mail], [let login stat() the mailbox]),
@@ -1265,6 +1275,7 @@ libuuid/uuid.pc
login-utils/Makefile
man/ru/Makefile
misc-utils/Makefile
+misc-utils/uuidd.service
mount/Makefile
partx/Makefile
po/Makefile.in