summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2011-10-27 10:32:24 +0200
committerKarel Zak2011-11-03 12:32:49 +0100
commit1dbbde662f210dd13471387849d789c5a9cb9489 (patch)
treec10a482a73bf37b35112fd688438d375d3d6a4bf /configure.ac
parentbuild-sys: rename and move macros (diff)
downloadkernel-qcow2-util-linux-1dbbde662f210dd13471387849d789c5a9cb9489.tar.gz
kernel-qcow2-util-linux-1dbbde662f210dd13471387849d789c5a9cb9489.tar.xz
kernel-qcow2-util-linux-1dbbde662f210dd13471387849d789c5a9cb9489.zip
build-sys: move --enable-lib{mount,uuid,blkid} before others --enable-*
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac126
1 files changed, 68 insertions, 58 deletions
diff --git a/configure.ac b/configure.ac
index 589667678..2fc9f77b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -324,45 +324,9 @@ if test "x$enable_most_builds" = xyes; then
enable_write=yes
fi
-AC_ARG_ENABLE([mount],
- AS_HELP_STRING([--disable-mount], [do not build mount utilities]),
- [], enable_mount=check
-)
-build_mount=yes
-if test "x$enable_mount" = xcheck; then
- if test "x$linux_os" = xno; then
- AC_MSG_WARN([non-linux system; do not build mount utilities])
- build_mount=no
- fi
-elif test "x$enable_mount" = xno; then
- build_mount=no
-fi
-AM_CONDITIONAL(BUILD_MOUNT, test "x$build_mount" = xyes)
-
-
-AC_ARG_ENABLE([fsck],
- AS_HELP_STRING([--disable-fsck], [do not build fsck]),
- [], enable_fsck=yes
-)
-AM_CONDITIONAL(BUILD_FSCK, test "x$enable_fsck" = xyes)
-
-
-AC_ARG_ENABLE([partx],
- AS_HELP_STRING([--disable-partx], [do not build addpart, delpart, partx]),
- [], enable_partx=check
-)
-build_partx=yes
-if test "x$enable_partx" = xcheck; then
- if test "x$linux_os" = xno; then
- AC_MSG_WARN([non-linux system; do not build partx utilities])
- build_partx=no
- fi
-elif test "x$enable_partx" = xno; then
- build_partx=no
-fi
-AM_CONDITIONAL(BUILD_PARTX, test "x$build_partx" = xyes)
-
-
+dnl
+dnl libuuid
+dnl
AC_ARG_ENABLE([libuuid],
AS_HELP_STRING([--disable-libuuid], [do not build libuuid and uuid utilities]),
[], enable_libuuid=yes
@@ -377,24 +341,9 @@ else
AC_MSG_WARN([uuid library is not found; mkswap(8) will not generate UUIDs])
fi
-
-AC_ARG_ENABLE([uuidd],
- AS_HELP_STRING([--disable-uuidd], [do not build the uuid daemon]),
- [], enable_uuidd=auto
-)
-
-case "$enable_uuidd:$enable_libuuid" in
-yes:no)
- AC_MSG_ERROR([cannot enable uuidd when libuuid is disabled]) ;;
-auto:*)
- enable_uuidd=$enable_libuuid ;;
-esac
-if test "x$enable_uuidd" = xyes; then
- AC_DEFINE(HAVE_UUIDD, 1, [Define to 1 if you want to use uuid daemon.])
-fi
-AM_CONDITIONAL(BUILD_UUIDD, test "x$enable_uuidd" = xyes)
-
-
+dnl
+dnl libblkid
+dnl
AC_ARG_ENABLE([libblkid],
AS_HELP_STRING([--disable-libblkid], [do not build libblkid and blkid utilities]),
[], enable_libblkid=yes
@@ -420,7 +369,9 @@ else
fi
fi
-
+dnl
+dnl libmount
+dnl
AC_ARG_ENABLE([libmount],
AS_HELP_STRING([--disable-libmount], [do not build libmount]),
[], enable_libmount=check
@@ -484,6 +435,65 @@ AC_DEFINE_UNQUOTED(LIBMOUNT_VERSION, "$LIBMOUNT_VERSION", [libmount version stri
AM_CONDITIONAL(BUILD_LIBMOUNT, test "x$build_libmount" = xyes)
+AC_ARG_ENABLE([mount],
+ AS_HELP_STRING([--disable-mount], [do not build mount utilities]),
+ [], enable_mount=check
+)
+build_mount=yes
+if test "x$enable_mount" = xcheck; then
+ if test "x$linux_os" = xno; then
+ AC_MSG_WARN([non-linux system; do not build mount utilities])
+ build_mount=no
+ fi
+elif test "x$enable_mount" = xno; then
+ build_mount=no
+fi
+AM_CONDITIONAL(BUILD_MOUNT, test "x$build_mount" = xyes)
+
+
+AC_ARG_ENABLE([fsck],
+ AS_HELP_STRING([--disable-fsck], [do not build fsck]),
+ [], enable_fsck=yes
+)
+AM_CONDITIONAL(BUILD_FSCK, test "x$enable_fsck" = xyes)
+
+
+AC_ARG_ENABLE([partx],
+ AS_HELP_STRING([--disable-partx], [do not build addpart, delpart, partx]),
+ [], enable_partx=check
+)
+build_partx=yes
+if test "x$enable_partx" = xcheck; then
+ if test "x$linux_os" = xno; then
+ AC_MSG_WARN([non-linux system; do not build partx utilities])
+ build_partx=no
+ fi
+elif test "x$enable_partx" = xno; then
+ build_partx=no
+fi
+AM_CONDITIONAL(BUILD_PARTX, test "x$build_partx" = xyes)
+
+
+
+AC_ARG_ENABLE([uuidd],
+ AS_HELP_STRING([--disable-uuidd], [do not build the uuid daemon]),
+ [], enable_uuidd=auto
+)
+
+case "$enable_uuidd:$enable_libuuid" in
+yes:no)
+ AC_MSG_ERROR([cannot enable uuidd when libuuid is disabled]) ;;
+auto:*)
+ enable_uuidd=$enable_libuuid ;;
+esac
+if test "x$enable_uuidd" = xyes; then
+ AC_DEFINE(HAVE_UUIDD, 1, [Define to 1 if you want to use uuid daemon.])
+fi
+AM_CONDITIONAL(BUILD_UUIDD, test "x$enable_uuidd" = xyes)
+
+
+
+
AC_ARG_ENABLE([libmount-mount],
AS_HELP_STRING([--enable-libmount-mount], [link mount(8) with libmount (EXPERIMENTAL)]),
[], enable_libmount_mount=no