summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2016-05-26 15:05:14 +0200
committerKarel Zak2016-05-26 15:08:53 +0200
commit1eb16fd78065dd6485731c4fb70924bc9b69df3a (patch)
tree76deb5ccf39a4e491bbc830860087af3c43f3076 /configure.ac
parentlibblkid: store only canonical devnames to the cache (diff)
downloadkernel-qcow2-util-linux-1eb16fd78065dd6485731c4fb70924bc9b69df3a.tar.gz
kernel-qcow2-util-linux-1eb16fd78065dd6485731c4fb70924bc9b69df3a.tar.xz
kernel-qcow2-util-linux-1eb16fd78065dd6485731c4fb70924bc9b69df3a.zip
build-sys: add --disable-plymouth-support
The plymouth support depends on Linux specific SOCK_* flags and all the feature is probably unnecessary in some cases (non-plymouth distros, etc.) Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 31 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b48a24a5e..f36b18c3c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -351,6 +351,22 @@ AC_CHECK_DECL([strsignal],
[Define to 1 if have strsignal function prototype])],
)
+AC_CHECK_DECL([TIOCGLCKTRMIOS],
+ [have_tiocglcktrmios=yes], [have_tiocglcktrmios=no],
+ [#include <sys/ioctl.h>])
+AC_CHECK_DECL([SOCK_CLOEXEC],
+ [have_sock_cloexec=yes], [have_sock_cloexec=no],
+ [#include <sys/types.h>
+ #include <sys/socket.h>])
+AC_CHECK_DECL([SOCK_NONBLOCK],
+ [have_sock_nonblock=yes], [have_sock_nonblock=no],
+ [#include <sys/types.h>
+ #include <sys/socket.h>])
+AC_CHECK_DECL([SO_PASSCRED],
+ [have_so_passcred=yes], [have_so_passcred=no],
+ [#include <sys/types.h>
+ #include <sys/socket.h>])
+
AC_CHECK_FUNCS([ \
__fpending \
secure_getenv \
@@ -1237,6 +1253,21 @@ AS_IF([test "x$have_futimens" = xyes -a "x$have_inotify_init1" = xyes ], [
])
+AC_ARG_ENABLE([plymouth_support],
+ AS_HELP_STRING([--disable-plymouth_support], [don not care about plymouth in sylogin(8) and agetty(8)]),
+ [], [UL_DEFAULT_ENABLE([plymouth_support], [check])]
+)
+UL_BUILD_INIT([plymouth_support])
+UL_REQUIRES_HAVE([plymouth_support], [tiocglcktrmios], [TIOCGLCKTRMIOS flag])
+UL_REQUIRES_HAVE([plymouth_support], [sock_cloexec], [SOCK_CLOEXEC flag])
+UL_REQUIRES_HAVE([plymouth_support], [sock_nonblock], [SOCK_NONBLOCK flag])
+UL_REQUIRES_HAVE([plymouth_support], [so_passcred], [SO_PASSCRED flag])
+AM_CONDITIONAL([USE_PLYMOUTH_SUPPORT], [test "x$build_plymouth_support" = xyes])
+AS_IF([test "x$build_plymouth_support" = xyes ], [
+ AC_DEFINE([USE_PLYMOUTH_SUPPORT], [1], [Enable plymouth support feature for sulogin and aggety])
+])
+
+
AC_ARG_WITH([libz],
AS_HELP_STRING([--without-libz], [compile without libz]),
[], [with_libz=auto]