summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2010-02-12 12:43:07 +0100
committerKarel Zak2010-02-12 12:43:07 +0100
commit2a7c1f70a66e8e165d0fa2da21c781c970d0f5ee (patch)
treea8444dea43375b9523bffa89e41c032dc58f280b /configure.ac
parentblkid: fix #ifdef HAVE_TERMIO[S]_H (diff)
downloadkernel-qcow2-util-linux-2a7c1f70a66e8e165d0fa2da21c781c970d0f5ee.tar.gz
kernel-qcow2-util-linux-2a7c1f70a66e8e165d0fa2da21c781c970d0f5ee.tar.xz
kernel-qcow2-util-linux-2a7c1f70a66e8e165d0fa2da21c781c970d0f5ee.zip
build-sys: add missing tests for libuuid and libblkid
$ make checkconfig misc-utils/blkid.c : HAVE_TERMIO_H misc-utils/blkid.c : HAVE_TERMIOS_H shlibs/blkid/src/getsize.c : HAVE_FSTAT64 shlibs/blkid/src/llseek.c : HAVE_LLSEEK_PROTOTYPE shlibs/blkid/src/llseek.c : HAVE_LSEEK64_PROTOTYPE shlibs/uuid/src/gen_uuid.c : HAVE_SA_LEN*/ shlibs/uuid/src/gen_uuid.c : HAVE_SYS_SOCKET_H shlibs/uuid/src/gen_uuid.c : HAVE_SYS_SYSCALL_H Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e36b8f6b8..9cc20b7ac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -126,6 +126,8 @@ AC_CHECK_HEADERS(
sys/prctl.h \
sys/queue.h \
sys/sockio.h \
+ sys/socket.h \
+ sys/syscall.h \
sys/file.h \
sys/ioctl.h \
sys/stat.h \
@@ -140,9 +142,24 @@ AC_CHECK_HEADERS([linux/raw.h],
AC_CHECK_DECLS([_NL_TIME_WEEK_1STDAY],[],[],[[#include <langinfo.h>]])
+AC_CHECK_DECL([llseek],
+ [AC_DEFINE(HAVE_LLSEEK_PROTOTYPE, 1,
+ [Define to 1 if have llseek prototype])],
+ [],
+ [#include <unistd.h>])
+
+AC_CHECK_DECL([lseek64],
+ [AC_DEFINE(HAVE_LSEEK64_PROTOTYPE, 1,
+ [Define to 1 if have lseek64 prototype])],
+ [],
+ [#define _LARGEFILE_SOURCE
+ #define _LARGEFILE64_SOURCE
+ #include <unistd.h>])
+
AC_CHECK_FUNCS(
[inet_aton \
futimens \
+ fstat64 \
fsync \
getdomainname \
get_current_dir_name \