summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2013-03-20 14:59:21 +0100
committerKarel Zak2013-03-20 14:59:21 +0100
commit312f04f497ef3587504767182678151fc56e4d83 (patch)
treee581a3886886a541df4d4296c09c2e2cb07568e9 /configure.ac
parentlibfdisk: (gpt) rmeove xalloc calls (diff)
downloadkernel-qcow2-util-linux-312f04f497ef3587504767182678151fc56e4d83.tar.gz
kernel-qcow2-util-linux-312f04f497ef3587504767182678151fc56e4d83.tar.xz
kernel-qcow2-util-linux-312f04f497ef3587504767182678151fc56e4d83.zip
build-sys: check for security_get_initial_context()
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3aae6eb2e..b32d024ff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -567,6 +567,13 @@ else
case "$with_selinux:$have_selinux" in
yes:no) AC_MSG_ERROR([SELinux selected but libselinux not found or too old]);;
esac
+
+ if test "x$have_selinux" = xyes; then
+ UL_SET_FLAGS([], [], [$SELINUX_LIBS])
+ # This function is missing in old libselinux 1.xx versions
+ AC_CHECK_FUNCS([security_get_initial_context])
+ UL_RESTORE_FLAGS
+ fi
fi
AC_SUBST([SELINUX_LIBS])
AC_SUBST([SELINUX_LIBS_STATIC])