summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2019-04-16 13:42:34 +0200
committerKarel Zak2019-04-16 13:42:34 +0200
commit31c66833cb8e3aad8af0eea4a1744e9e14f657b9 (patch)
tree34325c789284fd56291060001cda0f9791a2dc60 /configure.ac
parentchcpu: fix memory leak (diff)
downloadkernel-qcow2-util-linux-31c66833cb8e3aad8af0eea4a1744e9e14f657b9.tar.gz
kernel-qcow2-util-linux-31c66833cb8e3aad8af0eea4a1744e9e14f657b9.tar.xz
kernel-qcow2-util-linux-31c66833cb8e3aad8af0eea4a1744e9e14f657b9.zip
include/closestream: add close_stdout_atexit()
It seems better to have a way to control when atexit(close_stdout()) is used, because close stdout means that for example ASAN (or another into binary integrated tool) is not able to print the final summary. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cb72f42bd..d2c8f92fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -156,6 +156,8 @@ AC_ARG_ENABLE([asan],
AS_IF([test "x$enable_asan" = xyes], [
UL_WARN_ADD([-fsanitize=address])
ASAN_LDFLAGS="-fsanitize=address"
+],[
+ AC_DEFINE([USE_CLOSE_ATEXIT], [1], [close stdout at exit])
])
AC_SUBST([ASAN_LDFLAGS])