summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2015-07-27 11:49:29 +0200
committerKarel Zak2015-07-27 11:49:29 +0200
commit328eb4455b1dc8de16223702b5771a928cbcf86d (patch)
tree61557dafb046319debcdbd2aa9d8c6dd4bc6a878 /configure.ac
parentbuild-sys: fix test_colors build (diff)
downloadkernel-qcow2-util-linux-328eb4455b1dc8de16223702b5771a928cbcf86d.tar.gz
kernel-qcow2-util-linux-328eb4455b1dc8de16223702b5771a928cbcf86d.tar.xz
kernel-qcow2-util-linux-328eb4455b1dc8de16223702b5771a928cbcf86d.zip
build-sys: add --disable-cal
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c37d04401..7c4f6bcd5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1311,9 +1311,15 @@ AS_IF([test "x$build_mkswap" = xyes -a "x$build_libuuid" != xyes], [
AC_MSG_WARN([uuid library is not found; mkswap(8) will not generate UUIDs])
])
-UL_BUILD_INIT([cal], [yes])
+
+AC_ARG_ENABLE([cal],
+ AS_HELP_STRING([--disable-cal], [do not build cal]),
+ [], [UL_DEFAULT_ENABLE([cal], [check])]
+)
+UL_BUILD_INIT([cal])
AM_CONDITIONAL([BUILD_CAL], [test "x$build_cal" = xyes])
+
UL_BUILD_INIT([logger], [yes])
AM_CONDITIONAL([BUILD_LOGGER], [test "x$build_logger" = xyes])