summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChen Qi2015-08-31 10:23:45 +0200
committerKarel Zak2015-08-31 11:27:45 +0200
commit37edac9a0ca83f311279d2e49bacd6ac80310dc8 (patch)
treec043473a7c722626b3de751035bbbb511547a98c /configure.ac
parenttests: (cal) update US week numbers (diff)
downloadkernel-qcow2-util-linux-37edac9a0ca83f311279d2e49bacd6ac80310dc8.tar.gz
kernel-qcow2-util-linux-37edac9a0ca83f311279d2e49bacd6ac80310dc8.tar.xz
kernel-qcow2-util-linux-37edac9a0ca83f311279d2e49bacd6ac80310dc8.zip
build-sys: include errno.h instead of argp.h
configure should include errno.h instead of argp.h when checking for presence of program_invocation_short_name uclibc defines this to be const char* unlike util-linux-ng which defines this to be char* so this error goes unnoticed on glibc/eglibc systems. here is the error it fixes in file included from mountP.h:14:0, from cache.c:29: /home/kraj/work/slugos/build/tmp-slugos-uclibc/sysroots/nslu2le/usr/include/errno.h:55:46: error: conflicting types for '__progname' ../../../include/c.h:118:14: note: previous declaration of '__progname' was here make[3]: *** [cache.lo] Error 1 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Jonathan Liu <net147@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 547393c17..43ea7169c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -429,7 +429,7 @@ AS_CASE([$have_dirfd:$have_ddfd],
AC_MSG_CHECKING([whether program_invocation_short_name is defined])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- #include <argp.h>
+ #include <errno.h>
]], [[
program_invocation_short_name = "test";
]])], [