summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2011-10-27 15:56:05 +0200
committerKarel Zak2011-11-03 12:32:50 +0100
commit3c6e292ca3dc558a7b6949028167cdc3bcf04db8 (patch)
tree43ad290e1ad9bf2ea5b37ae63e4f8dd4c29f5238 /configure.ac
parentbuild-sys: cleanup BUILD_UNSHARE (diff)
downloadkernel-qcow2-util-linux-3c6e292ca3dc558a7b6949028167cdc3bcf04db8.tar.gz
kernel-qcow2-util-linux-3c6e292ca3dc558a7b6949028167cdc3bcf04db8.tar.xz
kernel-qcow2-util-linux-3c6e292ca3dc558a7b6949028167cdc3bcf04db8.zip
build-sys: cleanup BUILD_ARCH
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 15 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 70d50a91e..1e45f5e2d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,6 +103,17 @@ case ${host_os} in
esac
AM_CONDITIONAL([LINUX], test "x$linux_os" = xyes)
+dnl define ARCH_<NAME> conditionals
+UL_SET_ARCH(I86, i?86-*)
+UL_SET_ARCH(86_64, x86_64*)
+UL_SET_ARCH(IA64, ia64*)
+UL_SET_ARCH(S390, s390*)
+UL_SET_ARCH(SPARC, sparc*)
+UL_SET_ARCH(PPC, ppc*|powerpc*)
+UL_SET_ARCH(M68K, m68*)
+UL_SET_ARCH(MIPS, mips*)
+UL_SET_ARCH(HPPA, hppa*)
+
AC_SYS_LARGEFILE
AM_GNU_GETTEXT_VERSION([0.14.1])
@@ -748,21 +759,14 @@ if test "x$build_unshare" = xyes; then
fi
-UL_SET_ARCH(I86, i?86-*)
-UL_SET_ARCH(86_64, x86_64*)
-UL_SET_ARCH(IA64, ia64*)
-UL_SET_ARCH(S390, s390*)
-UL_SET_ARCH(SPARC, sparc*)
-UL_SET_ARCH(PPC, ppc*|powerpc*)
-UL_SET_ARCH(M68K, m68*)
-UL_SET_ARCH(MIPS, mips*)
-UL_SET_ARCH(HPPA, hppa*)
-
AC_ARG_ENABLE([arch],
AS_HELP_STRING([--enable-arch], [do build arch]),
[], enable_arch=no
)
-AM_CONDITIONAL(BUILD_ARCH, test "x$enable_arch" = xyes)
+build_arch=yes
+UL_REQUIRES_LINUX([arch])
+AM_CONDITIONAL(BUILD_ARCH, test "x$build_arch" = xyes)
+
AC_ARG_ENABLE([ddate],
AS_HELP_STRING([--enable-ddate], [do build ddate]),