summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2011-07-27 12:02:36 +0200
committerKarel Zak2011-07-27 12:02:36 +0200
commit3d92ed40e69d2620f43fadce22af13a993fe9d78 (patch)
tree889a09f187c6e544032e8e6b925130ff26be7b62 /configure.ac
parenthwclock: fix gcc warning (uninitialized variable) (diff)
downloadkernel-qcow2-util-linux-3d92ed40e69d2620f43fadce22af13a993fe9d78.tar.gz
kernel-qcow2-util-linux-3d92ed40e69d2620f43fadce22af13a993fe9d78.tar.xz
kernel-qcow2-util-linux-3d92ed40e69d2620f43fadce22af13a993fe9d78.zip
build-sys: enable mountpoint, add dependence on libmout
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 15 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index a02b5e31f..e2c3788f3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -484,14 +484,25 @@ AM_CONDITIONAL(BUILD_LIBMOUNT_MOUNT, test "x$enable_libmount_mount" = xyes)
AC_ARG_ENABLE([mountpoint],
- AS_HELP_STRING([--enable-mountpoint], [build mountpoint]),
- [], enable_mountpoint=no
+ AS_HELP_STRING([--disable-mountpoint], [build mountpoint]),
+ [], enable_mountpoint=check
)
-case "$enable_libmount:$enable_mountpoint" in
+
+build_mountpoint=yes
+if test "x$enable_mountpoint" = xcheck; then
+ if test "x$build_libmount" = xno; then
+ AC_MSG_WARN([libmount disabled; do not build mountpoint])
+ build_mountpoint=no
+ fi
+elif test "x$enable_mountpoint" = xno; then
+ build_mountpoint=no
+fi
+
+case "$build_libmount:$build_mountpoint" in
no:yes)
AC_MSG_ERROR([cannot enable mountpoint when libmount is disabled]) ;;
esac
-AM_CONDITIONAL(BUILD_MOUNTPOINT, test "x$enable_mountpoint" = xyes)
+AM_CONDITIONAL(BUILD_MOUNTPOINT, test "x$build_mountpoint" = xyes)
UTIL_CHECK_LIB(util, openpty)