summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavidlohr Bueso2012-02-27 18:26:40 +0100
committerKarel Zak2012-02-29 14:08:11 +0100
commit3dc02ef4080d5ea913a24ad759cc124ab6b514f4 (patch)
tree257edaf3bd701247b7d11269743637209ee5854d /configure.ac
parentinclude: add /proc/locks path to pathnames (diff)
downloadkernel-qcow2-util-linux-3dc02ef4080d5ea913a24ad759cc124ab6b514f4.tar.gz
kernel-qcow2-util-linux-3dc02ef4080d5ea913a24ad759cc124ab6b514f4.tar.xz
kernel-qcow2-util-linux-3dc02ef4080d5ea913a24ad759cc124ab6b514f4.zip
lslocks: new command
The new lslocks(8) program is meant to replace the deprecated lslk(8). It is designed for simplicity and removes unnecessary Unix legacy outputs and options: - Don't output inode number, whence and maj:min device numbers. - Don't provide nonblocking syscall options stat(2) and readlink(2) - Remove lslk's alternate default kernel name list file path (-k) The option to use nonblocking calls was previously intended for NFS partitions; however this should be transparent to utility programs considering that timeouts can occur generically (fuse - sshfs, NFS, netdevs, etc). Signed-off-by: Davidlohr Bueso <dave@gnu.org> Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b218341b1..b40a6361b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -892,6 +892,11 @@ if test "x$build_prlimit" = xyes; then
fi
+UL_BUILD_INIT([lslocks], [check])
+UL_REQUIRES_LINUX([lslocks])
+AM_CONDITIONAL(BUILD_LSLOCKS, test "x$build_lslocks" = xyes)
+
+
AC_ARG_ENABLE([switch_root],
AS_HELP_STRING([--disable-switch_root], [do not build switch_root]),
[], enable_switch_root=check