summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2011-03-16 17:03:48 +0100
committerKarel Zak2011-03-16 17:03:48 +0100
commit403e2d0c026d689baabcc4781d94ca09c2b87683 (patch)
treed177099970f70e29017b2983adc6519af6e897ee /configure.ac
parentlib: [fsprobe.c] use internal libblkid only (diff)
downloadkernel-qcow2-util-linux-403e2d0c026d689baabcc4781d94ca09c2b87683.tar.gz
kernel-qcow2-util-linux-403e2d0c026d689baabcc4781d94ca09c2b87683.tar.xz
kernel-qcow2-util-linux-403e2d0c026d689baabcc4781d94ca09c2b87683.zip
build-sys: don't support external (e2fsprogs) libuuid
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 1 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index 20d60befa..e12f1debb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -374,33 +374,12 @@ AC_ARG_ENABLE([libuuid],
AC_SUBST([LIBUUID_VERSION])
AC_SUBST([LIBUUID_VERSION_INFO])
AM_CONDITIONAL(BUILD_LIBUUID, test "x$enable_libuuid" = xyes)
-have_uuid=yes
-
-if test "x$enable_libuuid" = xno; then
- # Check for external (e2fsprogs) libuuid
- PKG_CHECK_MODULES(UUID, uuid, [have_uuid=yes], [have_uuid=no])
- if test "x$have_uuid" = xno; then
- # system without pkg-config or so, try classic check
- AC_CHECK_LIB(uuid, uuid_is_null, [have_uuid=yes], [have_uuid=no])
- fi
- if test "x$have_uuid" = xyes; then
- UTIL_SET_FLAGS($UUID_CFLAGS, $UUID_CFLAGS, $UUID_LIBS)
- AC_CHECK_HEADERS([uuid.h uuid/uuid.h], [break], [])
- UTIL_RESTORE_FLAGS
- fi
-else
- # internal library
- AC_DEFINE(HAVE_UUID_H, 1, [Define to 1 if you have the <uuid.h> header file.])
-fi
-if test "x$have_uuid" = xyes; then
+if test "x$enable_libuuid" = xyes; then
AC_DEFINE(HAVE_LIBUUID, 1, [Define to 1 if you have the -luuid.])
else
AC_MSG_WARN([uuid library is not found; mkswap(8) will not generate UUIDs])
fi
-AM_CONDITIONAL(HAVE_UUID, test "x$have_uuid" = xyes)
-# default
-: ${UUID_LIBS='-luuid'}
AC_ARG_ENABLE([uuidd],