summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRuediger Meier2016-02-18 16:37:13 +0100
committerRuediger Meier2016-02-18 16:54:05 +0100
commit40733239a79b5fd1c761e03942044a1b5a39bc36 (patch)
treed6950ac0d46f322f4ea0255d6746331bdea780a2 /configure.ac
parentlib: rename strmode() and setmode() (diff)
downloadkernel-qcow2-util-linux-40733239a79b5fd1c761e03942044a1b5a39bc36.tar.gz
kernel-qcow2-util-linux-40733239a79b5fd1c761e03942044a1b5a39bc36.tar.xz
kernel-qcow2-util-linux-40733239a79b5fd1c761e03942044a1b5a39bc36.zip
include: provide MAP_ANONYMOUS on OSX
Hope there are no side effect when defining _DARWIN_C_SOURCE globally. Signed-off-by: Ruediger Meier <ruediger.meier@ga-group.nl>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 17917af7b..5cee8cfa4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -158,11 +158,17 @@ bsd_os=no
AS_CASE([${host_os}],
[*linux*],
[linux_os=yes],
+ [*darwin*],
+ [darwin_os=yes],
[*bsd*],
[bsd_os=yes])
AM_CONDITIONAL([LINUX], [test "x$linux_os" = xyes])
+AM_CONDITIONAL([DARWIN], [test "x$darwin_os" = xyes])
AM_CONDITIONAL([BSD], [test "x$bsd_os" = xyes])
+AS_IF([test "x$darwin_os" = xyes], [
+ AC_DEFINE([_DARWIN_C_SOURCE], [1], [Enable MAP_ANON in sys/mman.h on Mac OS X])
+])
dnl define ARCH_<NAME> conditionals
UL_SET_ARCH([I86], [i?86-*])