summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2007-05-09 17:35:27 +0200
committerKarel Zak2007-05-17 12:53:52 +0200
commit40f07ff767e50d6e3b0e778d2c35f3c1e4d94106 (patch)
treea7e96400b761ca6e1cc1d5302415e27d6a5dfa44 /configure.ac
parentmount: fix has_* functions (CVE-2007-0822) (diff)
downloadkernel-qcow2-util-linux-40f07ff767e50d6e3b0e778d2c35f3c1e4d94106.tar.gz
kernel-qcow2-util-linux-40f07ff767e50d6e3b0e778d2c35f3c1e4d94106.tar.xz
kernel-qcow2-util-linux-40f07ff767e50d6e3b0e778d2c35f3c1e4d94106.zip
mount: fsprobe: add libvolume_id support to configure.ac
The patch add new option --with-fsprobe=<name> (where the <name> is blkid or volume_id). The blkid is default. The mount cannot be compiled without a filesystem detection library. Signed-off-by: Kay Sievers <kay.sievers@vrfy.org> Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 19 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2ee7e92a3..983ceab32 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,8 +71,26 @@ AC_DEFUN([UTIL_CHECK_LIB], [
UTIL_CHECK_LIB(uuid, uuid_is_null)
UTIL_CHECK_LIB(util, openpty)
UTIL_CHECK_LIB(termcap, tgetnum)
-UTIL_CHECK_LIB(blkid, blkid_known_fstype)
+AC_ARG_WITH([fsprobe],
+ AC_HELP_STRING([--with-fsprobe], [library to guess filesystems (blkid|volume_id), default is blkid]),
+ with_fsprobe=$withval, with_fsprobe=blkid
+)
+
+AM_CONDITIONAL(HAVE_BLKID, false)
+AM_CONDITIONAL(HAVE_VOLUME_ID, false)
+
+have_blkid=no
+have_volume_id=no
+if test x$with_fsprobe = xblkid; then
+ UTIL_CHECK_LIB(blkid, blkid_known_fstype)
+elif test x$with_fsprobe = xvolume_id; then
+ UTIL_CHECK_LIB(volume_id, volume_id_open_fd)
+fi
+
+if test $have_blkid = no && test $have_volume_id = no; then
+ AC_MSG_ERROR([Without blkid or volume_id you will not be able to build util-linux-ng.])
+fi
AM_GNU_GETTEXT_VERSION([0.14.1])
AM_GNU_GETTEXT([external])