summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRuediger Meier2016-02-08 15:32:26 +0100
committerRuediger Meier2016-02-29 13:05:11 +0100
commit42a4a152500fe507ed3eff491555d5ce1f2f6c08 (patch)
tree5ceefe8159ad98f3c5e2a43ab2cbfe50083ee4e1 /configure.ac
parentbuild-sys: disable login-utils if shadow.h or utmp.h is missing (diff)
downloadkernel-qcow2-util-linux-42a4a152500fe507ed3eff491555d5ce1f2f6c08.tar.gz
kernel-qcow2-util-linux-42a4a152500fe507ed3eff491555d5ce1f2f6c08.tar.xz
kernel-qcow2-util-linux-42a4a152500fe507ed3eff491555d5ce1f2f6c08.zip
build-sys: add --disable-ipcrm --disable-ipcs
ipcs's source history looks like some people are using it on BSD but it won't build on most non-Linux systems. That's why it's nice let "./configure --disable-ipcrm --disable-ipcs" work. Signed-off-by: Ruediger Meier <ruediger.meier@ga-group.nl>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ed61706ef..a5f878e68 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1420,10 +1420,18 @@ AM_CONDITIONAL([BUILD_FLOCK], [test "x$build_flock" = xyes])
UL_BUILD_INIT([ipcmk], [yes])
AM_CONDITIONAL([BUILD_IPCMK], [test "x$build_ipcmk" = xyes])
-UL_BUILD_INIT([ipcrm], [yes])
+AC_ARG_ENABLE([ipcrm],
+ AS_HELP_STRING([--disable-ipcrm], [do not build ipcrm]),
+ [], [UL_DEFAULT_ENABLE([ipcrm], [yes])]
+)
+UL_BUILD_INIT([ipcrm])
AM_CONDITIONAL([BUILD_IPCRM], [test "x$build_ipcrm" = xyes])
-UL_BUILD_INIT([ipcs], [yes])
+AC_ARG_ENABLE([ipcs],
+ AS_HELP_STRING([--disable-ipcs], [do not build ipcs]),
+ [], [UL_DEFAULT_ENABLE([ipcs], [yes])]
+)
+UL_BUILD_INIT([ipcs])
AM_CONDITIONAL([BUILD_IPCS], [test "x$build_ipcs" = xyes])
UL_BUILD_INIT([lsipc], [check])