summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2015-02-27 13:57:34 +0100
committerKarel Zak2015-02-27 13:57:34 +0100
commit4310faf9507b863adf0d735564f28db5c68ca600 (patch)
treee60620d3a69b9566e9e214cc316ccf2525bc116d /configure.ac
parentMerge branch 'fixes' of https://github.com/rudimeier/util-linux (diff)
downloadkernel-qcow2-util-linux-4310faf9507b863adf0d735564f28db5c68ca600.tar.gz
kernel-qcow2-util-linux-4310faf9507b863adf0d735564f28db5c68ca600.tar.xz
kernel-qcow2-util-linux-4310faf9507b863adf0d735564f28db5c68ca600.zip
lib/colors: use libtinfo to check terminal capability
The current implementation assumes that all terminals supports colors and users are forcet to use terminal-colors.d/ to disable colors for some terminals. This patch checks for maximal supported colors for the current terminal and colors are automatically disabled for terminals like vt100. The patch moves lib/colors.c from libcommon.la to libtcolors.la to avoid collisions with another utils. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 122b5d532..f7c3f8e57 100644
--- a/configure.ac
+++ b/configure.ac
@@ -778,6 +778,9 @@ PKG_CHECK_MODULES(TINFO, [tinfo], [have_tinfo=yes], [
AC_SUBST([TINFO_LIBS])
AC_SUBST([TINFO_CFLAGS])
AM_CONDITIONAL([HAVE_TINFO], [test "x$have_tinfo" = xyes])
+AS_IF([test "x$have_tinfo" = xyes],
+ AC_DEFINE(HAVE_LIBTINFO, 1, [Define if libtinfo available.])
+])
AC_ARG_WITH([utempter],