summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2012-04-04 12:18:32 +0200
committerKarel Zak2012-04-04 12:18:32 +0200
commit4581bd9c6797ea3b753c1d2019a37a84975d749a (patch)
tree29b80350ee9d64f924ed9340ce3d6741bf817177 /configure.ac
parentlsblk: use libmount to get mountpoints/swaps (diff)
downloadkernel-qcow2-util-linux-4581bd9c6797ea3b753c1d2019a37a84975d749a.tar.gz
kernel-qcow2-util-linux-4581bd9c6797ea3b753c1d2019a37a84975d749a.tar.xz
kernel-qcow2-util-linux-4581bd9c6797ea3b753c1d2019a37a84975d749a.zip
build-sys: disable chkdupexe by default, mark as deprecated
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 00d15b7f8..3085965de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,9 +114,6 @@ UL_SET_ARCH(M68K, m68*)
UL_SET_ARCH(MIPS, mips*)
UL_SET_ARCH(HPPA, hppa*)
-dnl script chkdupexe requires perl
-AC_PATH_PROG(PERL, perl)
-
AC_SYS_LARGEFILE
AM_GNU_GETTEXT_VERSION([0.14.1])
@@ -1082,6 +1079,19 @@ UL_BUILD_INIT([write])
AM_CONDITIONAL(BUILD_WRITE, test "x$build_write" = xyes)
+AC_ARG_ENABLE([chkdupexe],
+ AS_HELP_STRING([--enable-chkdupexe], [build deprecated chkdupexe]),
+ [], enable_chkdupexe=no
+)
+UL_BUILD_INIT([chkdupexe])
+AM_CONDITIONAL(BUILD_CHKDUPEXE, test "x$build_chkdupexe" = xyes)
+
+if test "x$build_chkdupexe" = xyes; then
+ AC_PATH_PROG(PERL, perl)
+ AC_CONFIG_FILES([misc-utils/chkdupexe:misc-utils/chkdupexe.pl])
+fi
+
+
AC_ARG_ENABLE([chsh-only-listed],
AS_HELP_STRING([--disable-chsh-only-listed], [chsh: allow shells not in /etc/shells]),
[], enable_chsh_only_listed=yes
@@ -1224,7 +1234,6 @@ libuuid/uuid.pc
login-utils/Makefile
man/ru/Makefile
misc-utils/Makefile
-misc-utils/chkdupexe:misc-utils/chkdupexe.pl
mount/Makefile
partx/Makefile
po/Makefile.in