summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSamuel Thibault2011-03-03 02:18:32 +0100
committerKarel Zak2011-03-11 12:34:25 +0100
commit465e9973848fc7398722b16d948a0d37cb51126f (patch)
treeaa00788f7e4848230b77405ca142333e6670d8b7 /configure.ac
parentcfdisk: add home and end keys movements in partition list (diff)
downloadkernel-qcow2-util-linux-465e9973848fc7398722b16d948a0d37cb51126f.tar.gz
kernel-qcow2-util-linux-465e9973848fc7398722b16d948a0d37cb51126f.tar.xz
kernel-qcow2-util-linux-465e9973848fc7398722b16d948a0d37cb51126f.zip
hwclock: build on non-Linux
Thanks to the direct ISA method and by disabling the RTC get/set epoch functionality, hwclock can work fine on non-Linux systems which provide ioperm or iopl. Signed-off-by: Samuel Thibault <samuel.thibault@ens-lyon.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9c3c5ac32..20d60befa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -220,6 +220,9 @@ AC_FUNC_FSEEKO
AC_CHECK_FUNCS([openat fstatat unlinkat], [have_openat=yes], [have_openat=no])
+AC_CHECK_FUNCS([ioperm iopl], [have_io=yes])
+AM_CONDITIONAL([BUILD_HWCLOCK], test "x$have_io" = xyes -o "x$linux_os" = xyes)
+
AC_CHECK_MEMBER(struct sockaddr.sa_len,
AC_DEFINE_UNQUOTED(HAVE_SA_LEN,1,[Define if struct sockaddr contains sa_len]),,
[#include <sys/types.h>