summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2013-04-17 17:35:47 +0200
committerKarel Zak2013-04-17 17:35:47 +0200
commit48469f9086b07f0c0c7c19996d78595045ac88cb (patch)
tree4edbdd72d4a39fccba10fa202fb894e7e8b4d0fb /configure.ac
parentsulogin: fix compiler warnings (diff)
downloadkernel-qcow2-util-linux-48469f9086b07f0c0c7c19996d78595045ac88cb.tar.gz
kernel-qcow2-util-linux-48469f9086b07f0c0c7c19996d78595045ac88cb.tar.xz
kernel-qcow2-util-linux-48469f9086b07f0c0c7c19996d78595045ac88cb.zip
fdisks: fix compiler warning
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f7adecb7d..afe0413df 100644
--- a/configure.ac
+++ b/configure.ac
@@ -183,6 +183,7 @@ AC_CHECK_HEADERS([ \
linux/raw.h \
linux/tiocl.h \
linux/version.h \
+ linux/securebits.h \
locale.h \
mntent.h \
net/if.h \
@@ -225,6 +226,7 @@ AC_CHECK_HEADERS([langinfo.h],
dnl Convert some ac_cv_header_* variables to have_*
dnl
have_linux_raw_h=$ac_cv_header_linux_raw_h
+have_linux_securebits_h=$ac_cv_header_linux_securebits_h
have_linux_watchdog_h=$ac_cv_header_linux_watchdog_h
have_security_pam_misc_h=$ac_cv_header_security_pam_misc_h
@@ -926,6 +928,7 @@ AC_ARG_ENABLE([setpriv],
)
UL_BUILD_INIT([setpriv])
UL_REQUIRES_LINUX([setpriv])
+UL_REQUIRES_HAVE([setpriv], [linux_securebits_h], [securebits.h header file])
UL_REQUIRES_HAVE([setpriv], [cap_ng], [libcap-ng])
AM_CONDITIONAL(BUILD_SETPRIV, test "x$build_setpriv" = xyes)