summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Santos2017-02-08 16:27:36 +0100
committerKarel Zak2017-02-09 11:31:49 +0100
commit4953018e23ba125272d9bcfd61a1a3040d211bf0 (patch)
treee072fca0b5b12554a1c415d26d8087200cc62157 /configure.ac
parentumount: exclude selinuxfs from --all (diff)
downloadkernel-qcow2-util-linux-4953018e23ba125272d9bcfd61a1a3040d211bf0.tar.gz
kernel-qcow2-util-linux-4953018e23ba125272d9bcfd61a1a3040d211bf0.tar.xz
kernel-qcow2-util-linux-4953018e23ba125272d9bcfd61a1a3040d211bf0.zip
build-sys: improve detection of the "isnan" function in uClibc
Since commit beceb14b450ded6560ed743634a5e80604a8edf3, MATH_LIBS is set to "-lm" when the isnan function is detected. In uClibc, however, isnan is a macro that calls __isnan, __isnanf, or __isnanl, depending on the size of the argument (double, float or long double). Fixes: http://autobuild.buildroot.net/results/2c2/2c29a78ed81ca844a87dcd076ab3e14ea080296d/ http://autobuild.buildroot.net/results/404/404b10f359b2ae8a7216729fa1bab37fed2d3d4c/ Signed-off-by: Carlos Santos <casantos@datacom.ind.br>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 37599212c..3bb3ba810 100644
--- a/configure.ac
+++ b/configure.ac
@@ -435,6 +435,7 @@ AM_CONDITIONAL([HAVE_OPENAT], [test "x$have_openat" = xyes])
AC_CHECK_FUNCS([isnan], [],
[AC_CHECK_LIB([m], [isnan], [MATH_LIBS="-lm"])]
+ [AC_CHECK_LIB([m], [__isnan], [MATH_LIBS="-lm"])]
)
AC_SUBST([MATH_LIBS])