summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2009-09-30 16:51:20 +0200
committerKarel Zak2009-09-30 16:51:20 +0200
commit4c24a7aed67282a49d5e133173c207bf35dcca4a (patch)
tree5e2fbcde11bf4c62fa5eb8e4ae9860e3474dd617 /configure.ac
parentlib: fix lib/Makefile.am (remove pttype.c) (diff)
downloadkernel-qcow2-util-linux-4c24a7aed67282a49d5e133173c207bf35dcca4a.tar.gz
kernel-qcow2-util-linux-4c24a7aed67282a49d5e133173c207bf35dcca4a.tar.xz
kernel-qcow2-util-linux-4c24a7aed67282a49d5e133173c207bf35dcca4a.zip
build-sys: add --disable-makeinstall-setuid
.. to disable "chmod 4755" for mount and umount. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b421d0a19..4f4cbb39a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -898,6 +898,12 @@ AC_ARG_ENABLE([makeinstall-chown],
)
AM_CONDITIONAL(MAKEINSTALL_DO_CHOWN, test "x$enable_makeinstall_chown" = xyes)
+AC_ARG_ENABLE([makeinstall-setuid],
+ AS_HELP_STRING([--disable-makeinstall-setuid], [do not do setuid chmod operations during "make install"]),
+ [], enable_makeinstall_setuid=yes
+)
+AM_CONDITIONAL(MAKEINSTALL_DO_SETUID, test "x$enable_makeinstall_setuid" = xyes)
+
AC_ARG_VAR([SUID_CFLAGS],
[CFLAGS used for binaries which are usually with the suid bit])