summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2012-07-16 17:42:09 +0200
committerKarel Zak2012-07-16 17:42:09 +0200
commit4e806975527240e159f727624de73d3e56778647 (patch)
tree6a09dc009cbf0254efb5dc8e2ff4fa24b86e922c /configure.ac
parentbuild-sys: exclude some CC warnings for clang (diff)
downloadkernel-qcow2-util-linux-4e806975527240e159f727624de73d3e56778647.tar.gz
kernel-qcow2-util-linux-4e806975527240e159f727624de73d3e56778647.tar.xz
kernel-qcow2-util-linux-4e806975527240e159f727624de73d3e56778647.zip
build-sys: add -Werror to UL_WARN_ADD test
... so revert previous patches with extra options for clang. Sometimes is simple solution so obvious that it's invisible :-) Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 4d89fc992..b98958ff2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,8 +98,6 @@ AC_C_CONST
AC_C_VOLATILE
AC_C_BIGENDIAN
-UL_PROG_CLANG
-
dnl Compiler warnings
UL_WARN_ADD([-Wextra])
UL_WARN_ADD([-Wno-missing-field-initializers])
@@ -112,9 +110,9 @@ UL_WARN_ADD([-fno-common])
UL_WARN_ADD([-Wunused-result])
UL_WARN_ADD([-Wmissing-prototypes])
UL_WARN_ADD([-Wunused-variable])
-UL_WARN_ADD([-Wmissing-parameter-type], [clang])
-UL_WARN_ADD([-Wunused-but-set-parameter], [clang])
-UL_WARN_ADD([-Wunused-but-set-variable], [clang])
+UL_WARN_ADD([-Wmissing-parameter-type])
+UL_WARN_ADD([-Wunused-but-set-parameter])
+UL_WARN_ADD([-Wunused-but-set-variable])
UL_WARN_ADD([-Wredundant-decls])
AC_SUBST([WARN_CFLAGS])